Version 2 - RC1 was released

Coordinator
Feb 16, 2011 at 2:26 AM

 

Would love to hear feedback on this release.  If there are no issues found in the next few weeks I will release as the official v2 release.

http://terminals.codeplex.com/releases/view/61030

 

Thanks.

Feb 16, 2011 at 8:42 AM

First test was to upgrade my current v1.9 on WIndows Seven, everything is fine and seems to works... I need to use it longer for better feedback! :-)

I will now check it out on a fresh setup (after having saved my connections and credentials! :-)

...

First negative feedback

After having opened the control panel to remove it, I have seen it double: one as ver 1.0.0 and one as ver 2.0.0. The msi should manage this situation. After having removed the latest the first entry was still available, of course trying to remove it give an error because it doesn't find the main .exe :-)

I did a "recover" directly from the v1.8c msi file and then I was able to remove it from the control panel

...

After the setup "from scratch" everything was fine. I will now restore back my credentials/connections and start using it! :-) More feedbacks in the next days...

Thank you

Ciao, Giangi

 

Feb 16, 2011 at 2:25 PM

Just ran the installer.  No showstoppers on install.

 

At this time the only comment I have is still no scrolling in telnet and SSH.  Is it on the hit list to be fixed in this release?

 

Thanks for a great product

Rborel

 

Feb 16, 2011 at 3:38 PM

I upgraded to the new version. Went well. kept my configuration and encrypted passwords. Connection to localdrives now works as expected. (Thanks!)

Everything looks good with RDP functionality. I use ssh with a small number of redhat systems. typically just use

putty user@host.mydomain

it prompts for password and I am in.

I have tried configuring for host or keyborad authenitcation both fail.

With connection configured for host authentication, in the terminals/logs/CurrentLog i get:

FATAL 2011-02-16 09:29:23,480 66051ms Terminals              Connect            - Connecting to SSH2 Connection

System.InvalidOperationException: Password property is not set

   at Routrek.SSHC.SSHConnection.Connect(SSHConnectionParameter param, ISSHConnectionEventReceiver receiver, Socket underlying_socket)

   at SSHClient.Protocol.Connect(Socket s)

   at Terminals.Connections.TerminalConnection.Connect()

Ok... while trying to document this problem. I set the authentication to password and retried. Conenction failed with same error message. Then I tried to save the password. IT WORKS that way.

So apparently, the problem is related to prompting for the password.

Thanks again for all your work on this great application!

Feb 18, 2011 at 8:06 AM

No problems for me in these few days, but I primarily use RDP without "fancy" options and just one VNC connection...

My only question is: how can I stop the opening of "Terminals news" http page on each first execution? :-)

Ciao, Giangi

PS: I think it's time to prepare a manual explaining the various options...

 

Feb 18, 2011 at 1:56 PM

This version is still having issues with UAC, prompting to run Terminals as an administrator 

I still use v1.7e daily since this was the last version that did not prompt for run as admin (I firmly believe running as local admin is bad form).

 

This has been posted on the discussion list before, please see:

http://terminals.codeplex.com/discussions/217166

Feb 19, 2011 at 2:12 PM
Edited Feb 19, 2011 at 2:13 PM

Not sure whether this is deliberate or not, but the default installation is set to only log FATAL errors.

On the subject of logging, the default installation is configured to minimize to tray and to allow more than one copy to be run at a time. Since Windows 7 defaults to hide the icon and only show Notifications, it makes it very easy to forget and open two or more copies. However since the first copy locks the log file, the second (and subsequent copies) won't be able to log anything. (Unless you happen to have a UDP viewer installed) (This has probably not a new change, but its the first time I noticed this)

Feb 20, 2011 at 1:57 PM

Where can I find the zip package?  I love Terminals and use it on all my machines so its easiest to have Windows Live Mesh just sync it around and not have to worry about an installer.  Great product, thanks for all your work!

Feb 21, 2011 at 10:08 AM

The second build seems to have lost the ability to save the RDP 'enable NLA  Authentication' option and the ICA 'Enable Encryption'.

Doesn't affect connections that are already setup correctly.

Looking at the source history, it looks like a few lines were lost when integrating Revision 85169  'Applied the security patch #6251' into Terminals/NewTerminalForm.cs

Feb 23, 2011 at 5:19 PM
Edited Feb 23, 2011 at 5:20 PM

This version is still having issues with UAC, prompting to run Terminals as an administrator. I log in as non-admin. (not big issue for me)

Tried 'upgrade' but new version would not run. Process fired up briefly and quit. I uninstalled. Got rid of the leftover v.1 in add/remove. Rebooted and reinstalled and it is fine. Even kept my connections.

I usually don't show the standar toolbar but found that closing all terminal sessions brings up that toolbar again. Not big issue as I usually have at least one open but have to remember to hide it before my first connection.

-c

Feb 28, 2011 at 6:35 PM

I am having the same issue as hjares

Mar 2, 2011 at 1:45 AM

Windows 7. Every time I minimize, Terminals quits. Boo. Not hiding in the tray. Just quits.

Also, I have the same UAC prompting as others.

Mar 2, 2011 at 4:09 AM

Another "me too" regarding the UAC.  I've always used the .zip version of Terminals from within a directory that I fully own (e.g. %USERPROFILE%\Documents\Apps\Terminals).  Also, I seem to be 'stuck' on 1.9a for not only this reason, but also because when I overwrite my installation directory with the new binaries from v2rc1 "Third Build" and then launch the new executable, I get alerted numerous times that my configuration was updated and my Terminals.config effectively becomes destroyed.  Good thing for backups!  Interestingly enough, I am unable to import the Favorites in v2rc1 "Third Build" that I exported from 1.9a.  What's the point of being able to do an export that the app itself can't even import?  Yes, I realize that the export is a (sloppy one-line) XML file that I can manually edit the config file and copy/paste the <favorites> section of the target config file, but this seems rather convoluted for the typical user.