This project has moved. For the latest updates, please go here.

New release issues / error

Topics: Developer Forum
Nov 3, 2011 at 12:44 PM

INFO  2011-11-03 07:40:05,669   244ms Terminals              Main               - Terminals 2.0 Alpha started
ERROR 2011-11-03 07:40:13,438  8013ms Terminals              DecryptPassword    - Error Decrypting Password
System.Security.Cryptography.CryptographicException: The parameter is incorrect.

   at System.Security.Cryptography.ProtectedData.Unprotect(Byte[] encryptedData, Byte[] optionalEntropy, DataProtectionScope scope)
   at Terminals.Functions.DecryptByEmptyKey(String encryptedPassword) in C:\source\CodePlex\Terminals\Terminals\Terminals\Data\Functions.cs:line 58
   at Terminals.Functions.DecryptPassword(String encryptedPassword, String keyMaterial) in C:\source\CodePlex\Terminals\Terminals\Terminals\Data\Functions.cs:line 28
INFO  2011-11-03 07:40:42,108 36683ms Terminals              TryLoadHistory     - Loading History from: History.xml
INFO  2011-11-03 07:40:42,110 36685ms Terminals              SaveHistory        - Saving History
INFO  2011-11-03 07:40:42,271 36846ms Terminals              SaveHistory        - Done Saving History
INFO  2011-11-03 07:40:42,275 36850ms Terminals              SaveHistory        - Save History Duration:164ms
INFO  2011-11-03 07:40:42,275 36850ms Terminals              TryLoadHistory     - Done Loading History
INFO  2011-11-03 07:40:42,275 36850ms Terminals              LoadHistory        - Load History Duration:167ms
INFO  2011-11-03 07:41:18,521 73096ms Terminals              Main               - Terminals 2.0 Alpha stopped
INFO  2011-11-03 07:41:20,314   211ms Terminals              Main               - Terminals 2.0 Alpha started
INFO  2011-11-03 07:41:27,275  7171ms Terminals              TryLoadHistory     - Loading History from: History.xml
INFO  2011-11-03 07:41:27,464  7360ms Terminals              TryLoadHistory     - Done Loading History
INFO  2011-11-03 07:41:27,464  7360ms Terminals              LoadHistory        - Load History Duration:189ms


The fav menu is now empty and does not populate with my saved servers like the old version did. I tried starting from a fresh build, and importing my favs, but the menu simply does not populate.

Nov 3, 2011 at 12:49 PM

The favorites panel works correctly, however the favorites menu item is empty.

Coordinator
Nov 4, 2011 at 9:22 PM

- Passwords in credentials were not applied properly because of wrong published build, now it should work in current build

- Untagged menu item was added to the menu and tray menu

Nov 7, 2011 at 3:12 PM

Still getting error with new build.  (Build from 11/3 @ 23:12)

ERROR 2011-11-07 09:10:27,639 17113ms Terminals              DecryptPassword    - Error Decrypting Password
System.Security.Cryptography.CryptographicException: The parameter is incorrect.

   at System.Security.Cryptography.ProtectedData.Unprotect(Byte[] encryptedData, Byte[] optionalEntropy, DataProtectionScope scope)
   at Terminals.Functions.DecryptByEmptyKey(String encryptedPassword) in C:\source\CodePlex\Terminals\Terminals\Terminals\Data\Functions.cs:line 58
   at Terminals.Functions.DecryptPassword(String encryptedPassword, String keyMaterial) in C:\source\CodePlex\Terminals\Terminals\Terminals\Data\Functions.cs:line 28
ERROR 2011-11-07 09:10:27,717 17191ms Terminals              DecryptPassword    - Error Decrypting Password

I have a ton of sites, this is a real pain to have to go look all these up again.

Coordinator
Nov 7, 2011 at 6:11 PM

- Favorites menu was empty because of Untagged items.

@c567591: In previous beta version, there was an bug in manipulation with master password. Try to remove the favorite password and assign new one. Then let me know, if it helped. Otherwise provide all steps, how i can reproduce it on clean installation.

Thank you very much for your help.

Nov 7, 2011 at 6:30 PM

Never had a master password assigned.

I did this and then re-cleared it and still have no use of prior credentials.  Any that i had to fix so far this am still work, but any untried are still not sending the credentials correctly.

Nov 9, 2011 at 8:06 AM
jirkapok wrote:

- Untagged menu item was added to the menu and tray menu

...not in Beta3... at least I do not see any "untagged" entries into the Favorites menu!

CIao, Giangi

Nov 9, 2011 at 8:36 AM
jirkapok wrote:

- Passwords in credentials were not applied properly because of wrong published build, now it should work in current build

Not in Beta3, the error is still there... :-(

Nov 9, 2011 at 8:39 AM
jirkapok wrote:

In previous beta version, there was an bug in manipulation with master password. Try to remove the favorite password and assign new one. Then let me know, if it helped. Otherwise provide all steps, how i can reproduce it on clean installation.

Details in my message into http://terminals.codeplex.com/discussions/276481

Basically you just have to enable/disable the Favorites Panels into the Options to destroy credentials.xml!