This project has moved. For the latest updates, please go here.

Running Terminals On A Terminal Server

Topics: Developer Forum, Project Management Forum, User Forum
Apr 13, 2012 at 9:21 PM

First off this product is awesome keep up on the good work !!   I know this sounds crazy but we actually have a need for this. I use this on my laptop and it's awsome !!!!! however i'm sick of having to setup other techs on vpn to access our 1000's of terminal servers.  So what i'm attempting to do is this -

1.) setup a terminal server that runs remote app for the program Terminals ( done)

2.) have each tech be able to login to Terminals , setup there credentials , and use the pre- populated list to launch all connectestions they need.

issues -

*only 1 user can have terminals open at a time or it crashes ( opens and closes right away )

* default credentials can only be saved by the first person to setup and install the program. ( i did find a viable workaround to this using credential manager)

* the ad sync did not work on the new version. insatlled the old on synced it right up first time i tried. reinstalled the new version and all my imported servers were there but it still would not sync with AD when i tried again using the newest build. Sits at contacting domain.

* the sharing of the server list is nice becasue only 1 user has to update the list and every one can see it.

 

Any tips or help would be appreciated !

~Josh

 

 

Coordinator
Apr 13, 2012 at 10:13 PM

1. run Terminals as remote app is definitely not tested scenario. I am expecting concurrent locks between processes.

2. current version works with files in its directory. This disables most users to make changes. Workaround is to redirect the data files to shared directory using command line options (see documentation)

3. "AD sync" do you mean "scan AD to import favorites"? Because i tested this feature of our domain and i usually takes long time to connect to the domain.
Can you describe more detailed this issue.

Apr 13, 2012 at 10:29 PM

I let it sit for over an hr and it just sat at the first propmpt connecting to domain .   i uninstalled , resinstalled the old version the scan took about 15 seconds to come up with all the results. Its all local so it was pretty quick. the new version just sat there and did not error out.  if you need logs or anthing let me know  . 

one of the things i was going to try was virtualizing the application to see if that worked. i have a feeling it might . that should fix the multiple user problem.

Apr 13, 2012 at 11:31 PM

and i know this is open source is anyone avalible for hire to help us make the software do the above request's?  

 

Coordinator
Apr 15, 2012 at 9:14 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.