This project has moved. For the latest updates, please go here.

Amazon S3 Backup/Restore

Topics: User Forum
Nov 23, 2008 at 1:31 AM
Edited Nov 23, 2008 at 1:33 AM
I had backed up 1.7b to Amazon S3 and it was successful and the 'Test' also worked though when opening 1.7c 'Test' worked but 'Restore' gave the error 'access denied'

Is there a particular 'bucket' that Terminals is trying to dump into, when I browse my Amazon S3 with Firefox S3 Addon I see no actual backup file or extra files that appear to be from Terminals.
Nov 26, 2008 at 1:27 PM
After just having my terminals.config file vanish I tried again to restore from S3 though there was nothing to restore.

I have just redone ~half of my RDP connections into the Favorites (i.e. Terminals.config) and have tried again to 'Backup to S3'

The 'Test' replies with 'Test was successful!' but backup does nothing nor restore, also directly looking at my S3 files/buckets etc I see nothing resembling a backup to Terminals.
Coordinator
Dec 9, 2008 at 5:25 PM
It should be creating a remote folder named "Terminals" with the config file uploaded into it.

What I should do is nab a copy of terminals.config  (to Terminals.bak) prior to downloading/restoring from S3 --probably a good idea!

Is there anytihng relevant in the logs\CurrentLog.txt file?

Dec 9, 2008 at 10:54 PM

Now that I have logs running here is the result:-

INFO  2008-12-10 09:37:28,110  1207ms Terminals              Main               - Terminals 1.7c started
FATAL 2008-12-10 09:42:33,313 306410ms Terminals              on_ThreadException - Application Exception
Affirma.ThreeSharp.ThreeSharpException: The requested bucket name is not available. The bucket namespace is shared by all users of the system. Please select a different name and try again.
   at Affirma.ThreeSharp.Query.ThreeSharpQuery.ThrowIfErrors(HttpWebResponse httpWebResponse) in C:\Source\Terminals\Affirma.ThreeSharp\Query\ThreeSharpQuery.cs:line 292
   at Affirma.ThreeSharp.Query.ThreeSharpQuery.Invoke[T](Request request) in C:\Source\Terminals\Affirma.ThreeSharp\Query\ThreeSharpQuery.cs:line 218
   at Affirma.ThreeSharp.Query.ThreeSharpQuery.BucketAdd(BucketAddRequest request) in C:\Source\Terminals\Affirma.ThreeSharp\Query\ThreeSharpQuery.cs:line 61
   at Affirma.ThreeSharp.Wrapper.ThreeSharpWrapper.AddBucket(String bucketName) in C:\Source\Terminals\Affirma.ThreeSharp.Wrapper\ThreeSharpWrapper.cs:line 48
   at Terminals.OptionsForm.BackupButton_Click(Object sender, EventArgs e) in C:\Source\Terminals\Terminals\OptionsForm.cs:line 336
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Ideally it would be good then if in the Amazon S3 section we can have a field to insert our own 'bucket name' of choice here.

I am fairly new to Amazon S3 and I have the Firefox S3 Browser add-in installed and also Cloudberry and through either interface I had not been able to find my own 'Terminals Bucket' and I also have a similar issue with another piece of software that does some funky S3 stuff for me that I have a similar issue with a common 'bucket name' being attached to the application and the application fails as the 'bucket cannot be created' so I will try in that app to modify the source to a different 'bucket name' and see how that app handles the bucket name change and if it then works I will update here.

Cheers,

Stephen

Jul 25, 2009 at 9:17 PM

I'm getting the same problem. No folder in S3 called Terminals, even though there is no error message. The connection Test works fine.

Mar 4, 2010 at 6:24 PM

> It should be creating a remote folder named "Terminals"

Does this mean it is creating a bucket called Terminals? If so, then this will not work as, according to Amazon  'bucket names must be unique across all of Amazon <acronym>S3</acronym>.' - (strictly speaking it will work, but only for the first person who tried this as they will own the bucket called Terminals and no-one else will be able to access it).

 

 

 

Mar 5, 2010 at 1:11 PM
Edited Mar 5, 2010 at 1:16 PM

Essentially we should have another 'Input Field' on the following options tab so that we can name our own 'Amazon S3 Folder Name' eg. 'StephenS3_Terminals'

 

Terminals S3 Backup

 

The 'Test' is working and authenticating our 'Access Key ID' & 'Secret Access Key' and that test is successful. We need to be able to name our own 'bucket' folder name and if it does not exist it is then created, if it already exists it should return the error listed above 'The requested bucket name is not available. Please select a different name and try again.'