No 'log' folder and no 'log' files for 1.7c ?

Topics: User Forum
Nov 30, 2008 at 6:32 PM
Finally got Terminals to work.  Wow!  Worth every minute I spent on it!  Awesome creation!

At first I couldn't connect with 1.7c, it tells me to either 'try again' or 'check the log file', but there is no log file or folder anywhere.

I had to download 1.7b, and found the 'log' folder and file in there that finally told me it was the 'Class not registered' error, which led me to do the command console thing:

regsvr32 C:\WINDOWS\system32\mstscax.dll

to mannally register the thing. Voila!  All is heaven.  But where is the 'log' folder in 1.7c to begin with?  :-)

Love your work, love it love it love it.
Tiger


Dec 5, 2008 at 11:20 PM
The \logs subfolder is not there now that you have pointed it out. I have it under the previous 1.7b version but none for 1.7c

Cheers,

Stephen
Dec 6, 2008 at 5:41 PM
So where is the log file then?  I can't find it anywhere for 1.7c.  Are you saying there is no logging for 1.7c?  If so, is this a temporary thing?

Thx
Tiger
Dec 8, 2008 at 4:28 AM
I have no logs for 1.7c as stated above and must be a bug for 1.7c
Coordinator
Dec 9, 2008 at 5:14 PM
Check the folder which terminals.exe is running from, for a file:

Terminals.log4net.config

Contents should be:

<?xml version="1.0" encoding="utf-8" ?>
<log4net>
  <appender name="RollingLogFileAppender" type="log4net.Appender.RollingFileAppender">
    <file value="logs\\CurrentLog.txt" />
    <appendToFile value="true" />
    <datePattern value="yyyyMMdd" />
    <rollingStyle value="Date" />
    <filter type="log4net.Filter.LevelRangeFilter">
      <acceptOnMatch value="true" />
      <levelMin value="INFO" />
      <levelMax value="FATAL" />
    </filter>
    <layout type="log4net.Layout.PatternLayout">
      <conversionPattern value="%-5p %d %5rms %-22.22c{1} %-18.18M - %m%n" />
    </layout>
  </appender>

  <root>
    <level value="ALL" />
    <appender-ref ref="RollingLogFileAppender" />
  </root>
</log4net>

Dec 9, 2008 at 10:33 PM
Edited Dec 9, 2008 at 10:40 PM
I do NOT have a 'Terminals.log4net.config' in my 1.7c folder.

I DO have a 'Terminals.log4net.config' in my old 1.7b folder.

The Terminals 1.7b Distribution package from Codeplex here INCLUDES the 'Terminals.log4net.config' file and the 1.7c distribution package does NOT include this file.

Cheers,

Stephen

EDIT: Just comparing the XML code above to the 1.7b version I have it appears the same so I have copied the 1.7b file to my 1.7c install and I now have log files (i.e CurrentLog.txt) being generated in Terminals 1.7c \logs folder