Missing Top Menu Bar

Apr 23, 2013 at 12:58 PM
I don't know what menu option or key combination I accidentally choose but I no longer have a menu bar on top.

To have this as an option to hide is fine, but for the fact that I can no longer "add" a new connection (green plus icon).

Any suggestions as to how to get this back?
Image
Coordinator
Apr 23, 2013 at 4:10 PM
I was not able to reproduce. The only option, which hides all panels is FullScreen mode. Try F11 shortcut or Delete toolstrips xml file in application directory (version 2.0).
Apr 26, 2013 at 10:29 PM
Deletion (I renamed to Old_ToolStrip.settings.config) fixed the missing menu.

Location of file is:
C:\Program Files (x86)\Terminals\


I will post if find root cause.
Aug 29, 2013 at 4:26 PM
I also had this happen (using 3.2.0), not sure why. I tried renaming the ToolStrip.settings.config but upon launch I had the same issue (Terminals recreated the file and it was the same as the old copy). I downloaded 3.3.0 and copied the ToolStrip.settings.config from that install over the one in 3.2.0 and then my issue was resolved.
Jun 30, 2014 at 2:51 PM
Edited Jun 30, 2014 at 2:52 PM
I just ran into this with 3.5.0

Removing ToolStrip.settings.config from C:\Program Files (x86)\Terminals\Data fixed it ( \Data is not mentioned above ).
The ToolStrip.settings.config in C:\Program Files (x86)\Terminals is the default one.
Sep 17, 2014 at 3:25 PM
i just installed 3.5 for the first time. after importing RDCman and opening and lcosing a few times i have lost the file menu and menu bar... i have tried the suggestions above but that did not work. i did a repair install. still not working.... help!
Developer
Sep 22, 2014 at 12:40 AM
Depedending on type of your install, the file can live only in two directories:
  • Program Files/Terminals/Data
  • c:\Users\YourUserName\AppData\Local\Robert_Chartier\Terminals\Data\
Sep 24, 2014 at 7:14 PM
thanks i got it working now.
Great program!
Oct 30, 2014 at 5:54 PM
KarlosChuar wrote:
Depedending on type of your install, the file can live only in two directories:
  • Program Files/Terminals/Data
  • c:\Users\YourUserName\AppData\Local\Robert_Chartier\Terminals\Data\
I also had this happen in version 3.5. My menu strip and standard toolbar disappeared. I am running this on Windows 7.

I had the file ToolStrip.settings.config file residing in these two locations:

c:\Program Files (x86)\Terminals
(* Note: No Data subfolder)
c:\Users\YourUserName\AppData\Local\Robert_Chartier\Terminals\Data\


The file located in the users path appears to take precedence. In trying to fix the issue I changed the following setting from false to true in the file located in the default path. The change had no effect on the application.

<ToolStripSetting xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <Name>toolbarStd</Name>
    <Visible>true</Visible>
I then made the same change in the file located in the users path and the standard toolbar was back.

While in this file I noticed that the menu strip setting was set to false and changed that to true as well. As expected the menu strip became visible.

<ToolStripSetting xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <Name>menuStrip</Name>
    <Visible>true</Visible>

The loss of the menu strip and standard toolbar seemed to coincide around the time I was making some changes within the application and when installing another RDS management tool. Below were the changes:

1) Import of connections
2) Hiding of shortcuts toolbar and favorites toolbar
3) Disabling of minimize to tray setting from the options menu item
4) Installation of Remote Desktop Connection Manager from MS


I'm leaning toward the last installation of the RDCMan.msi application as being the cause of the issue...but that being said, I may have disabled the standard toolbar when I disabled the shortcuts toolbar and favorites toolbar from within the application. I have no idea as to how the menu strip would disappear. I don't recall that option in the application.


If I have a chance to troubleshoot later I will try and replicate. Sorry I couldn't narrow the issue further at this point in time.


Thanks to all those who have worked on this application. This is an awesome/excellent application. I could not achieve the higher level of efficiency in system administration without this application. Thank you! Thank you! Thank you!
Feb 5, 2015 at 5:51 PM
I realize OP is mostly resolved already but to help others most of the time just be sure Terminals has focus and no dialogue boxes are open when you type the function key F11 at the top of your keyboard. Also if you don't have the shortcuts bar at the top of favorites you can also add new favorites while in full screen hit the key combination ctrl + n or ctrl + f this will bring up a separate dialogue. Also ctrl + shift + P brings up the options. Make sure terminals has focus hit Esc to close any dialogue boxes and then F11. These steps have worked for me in the past your mileage may vary.
Jul 10, 2015 at 4:25 PM
Sorry for my bad English

You need to have Terminals minimize to tray. Then you clic right on the icone minimize and clic on Show/Hide Menu.
If Terminals dont minimize to tray, then you need to active this option: ctrl + shift + P brings up the options / Interfaces / Chek minimize to tray.

Thks to the devs, i use this wonderful application all day.