Problem transferring favorites

Topics: User Forum
May 30, 2013 at 9:36 PM
I got a new windows 8 system. When I selected all the favorites to export, the application fails and then closes. Nothing is in the xml file specified.
If I select only a subset, the export appears to work. But then when I go to my new laptop running the same version, and do the import, it initially says import successful. It actually shows the list of my favorites.

Then when I go to the favorites pull down, nothing is there.

Just for fun I downloaded and installed the latest build. Same problem.

New system is running:
This version of terminals was build for you on Monday, May 27, 2013 at 1:20:26 PM

Version: 3.0.1.0
CommandLine: "C:\Program Files (x86)\Terminals\Terminals.exe"
CurrentDirectory: C:\Program Files (x86)\Terminals
MachineName: ANOMALY2
OSVersion: Microsoft Windows NT 6.2.9200.0
ProcessorCount: 8
UserInteractive: True
Framework Version: 4.0.30319.18046
WorkingSet: 63643648
Is 64bit OS: True
Is 64bit Proces: True
Coordinator
May 31, 2013 at 7:50 AM
Can you provide log file?
Jun 19, 2013 at 5:46 PM

Thank you for your help on this great application. I have used it for quite a while. I was hooing to be able to export my favorites from my old laptop and import them to this new installation. That was the subject of the original question.

Recently I uninstalled terminals out of frustration with the new version. I also recently got a new laptop running Windows 8 Pro. (This might complicate things too.)

So the other day I reinstalled the version named TerminalsSetup_V3.0_Beta2.msi.

Installation went fine.

I was hoping to just add my favorites manually.

I added one exited the application, went back and the favorite was gone.

Just on a hunch I restarted the application with “run as administrator”. I was able to save a favorite.

This morning I launched the application using the Windows 8 desktop icon. The favorite from the other day was still there.

Of course today I needed to work on a different system. I clicked the star icon to “Organize Favorites”. The original favorite was there. I added my new one. Did “Save and close”.

I immediately noticed that the Connect to selection box was now blank… when I click on pull down, no favorites appear.

When I click on organize favorites, there is nothing.

CurrentLog.txt has:

INFO 2013-06-19 10:06:51,048 188ms Terminals Main - -------------------------------Title: Terminals 3.0.1.0 started Version:3.0.1.0 Date:4/28/2013 5:22:47 PM-------------------------------

INFO 2013-06-19 10:06:51,107 247ms Terminals Main - Start state 1 Complete: Unhandled exceptions

INFO 2013-06-19 10:06:51,108 248ms Terminals gGeneralProperties - CommandLine:"C:\Program Files (x86)\Terminals\Terminals.exe"

INFO 2013-06-19 10:06:51,109 249ms Terminals gGeneralProperties - CurrentDirectory:C:\Program Files (x86)\Terminals

INFO 2013-06-19 10:06:51,109 249ms Terminals gGeneralProperties - MachineName:ANOMALY2

INFO 2013-06-19 10:06:51,109 249ms Terminals gGeneralProperties - OSVersion:Microsoft Windows NT 6.2.9200.0

INFO 2013-06-19 10:06:51,110 250ms Terminals gGeneralProperties - ProcessorCount:8

INFO 2013-06-19 10:06:51,110 250ms Terminals gGeneralProperties - UserInteractive:True

INFO 2013-06-19 10:06:51,110 250ms Terminals gGeneralProperties - Version:4.0.30319.18046

INFO 2013-06-19 10:06:51,111 251ms Terminals gGeneralProperties - WorkingSet:23109632

INFO 2013-06-19 10:06:51,111 251ms Terminals gGeneralProperties - Is64BitOperatingSystem:True

INFO 2013-06-19 10:06:51,112 252ms Terminals gGeneralProperties - Is64BitProcess:True

INFO 2013-06-19 10:06:51,112 252ms Terminals Main - Start state 2 Complete: Log General properties

INFO 2013-06-19 10:06:51,113 253ms Terminals Main - Start state 3 Complete: Set application properties

INFO 2013-06-19 10:06:51,152 292ms Terminals Main - Start state 4 Complete: Parse command line

INFO 2013-06-19 10:06:51,154 294ms Terminals Main - Start state 5 Complete: User account control

INFO 2013-06-19 10:06:51,156 296ms Terminals Main - Start state 6 Complete: Set Single instance mode

INFO 2013-06-19 10:06:51,157 297ms Terminals Main - Start state 7 Complete: Configuration upgrade

INFO 2013-06-19 10:06:51,168 308ms Terminals TryLoadFile - Loading History from: C:\Users\howard\AppData\Local\Robert_Chartier\Terminals\Data\History.xml

ERROR 2013-06-19 10:08:37,493 106633ms Terminals LoadDevices - Error loading a drive into the tree

System.IO.IOException: The device is not ready.

at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

at System.IO.DriveInfo.get_VolumeLabel()

at Terminals.DiskDrivesForm.LoadDevices()

ERROR 2013-06-19 10:08:37,600 106740ms Terminals LoadDevices - Error loading a drive into the tree

System.IO.IOException: The device is not ready.

at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

at System.IO.DriveInfo.get_VolumeLabel()

at Terminals.DiskDrivesForm.LoadDevices()

I checked on the properties of the desktop icon:

Any assistance would be appreciated. I would be happy to test/try a new version if needed.

Howard Jares

University of Houston