This project has moved and is read-only. For the latest updates, please go here.

3.3 won't stay maximized

Nov 26, 2013 at 11:01 PM
In most applications, and in previous versions of this application, when I opened it, then maximized it to the window, upon close and reopen of the window, it would re-open maximized on the screen, but with 3.3, it re-opens as a small free floating window. Then, if I connect to an RDP session, when the last one disconnects, the Terminals window once again resizes itself to not be maximized.

Any help?
Nov 27, 2013 at 4:53 PM
Edited Nov 27, 2013 at 4:54 PM
Try changing the Terminals.config file located at Terminals\Data. Change the state value of the MainForm to Maximized.

<add name="MainForm" size="1601, 857" location="1, 2" state="Maximized" />
Nov 27, 2013 at 8:00 PM
Well, I downgraded to 3.2 and I'm no longer having the issue...so while I didn't try your little trick, something changed between the two versions that's not honoring some system value or another....
Dec 3, 2013 at 11:22 PM
I'm having the same issue. Can you provide any additional information for this change? I can't find a Terminals.config file or Terminals\Data folder. I do see a Terminals.exe.config file in the C:\Program Files\Terminals folder, but don't see any section in it labeled MainForm. Thanks!
Dec 4, 2013 at 3:34 PM
I did a search on my computer and found the Terminals.config file at the location of C:\Users\<myname>\AppData\Local\Robert_Chartier\Terminals\Data on my computer. I made the change and set the MainForm stat to Maximized, but it did not correct the issue. It opened maximixed but then immediately went back to the Normal state. When I closed it, then opened the Terminals.config file, I found it was set back to Normal. I tried it again, made sure the windows was Maximized when I closed it, but it still opens in the Normal state. I also found a setting called 'RestoreWindowOnLastTerminalDisconnect' which was set to true. I tried setting it to false, but that didn't work either. For some reason, it seems this version always stays in the normal state in terms of screen size. Any other suggestions?
Dec 4, 2013 at 6:09 PM
I had the same problem, and just now fixed it by unticking "Automatically restore main window when the last connection is closed" in Tools | Options | Connections. I first tried changing that value via the config (like you), but obviously that didn't work.
Dec 4, 2013 at 6:53 PM
Does that fix the problem of it restoring (un-maximizing) on close and re-open?


Dec 4, 2013 at 6:59 PM
Nope, the problem still occurs when restarting the program. I also tried to set it to launch maximized, but that didn't work...
Dec 4, 2013 at 7:04 PM
I'll stay on 3.2 for the time being then :)


Dec 4, 2013 at 9:01 PM
I tried the solution 'IDontExist' suggested and that's not working for me either. That likely the setting I found in the Terminals.config file called 'RestoreWindowOnLastTerminalDisconnect', which didn't work either. If 'Ijlongwing' is correct, there must be something else in the 3.3 version code preventing this from working properly. Can anyone assist with this issue?