This project has moved. For the latest updates, please go here.

Cannot connect to VNC or SSH

Topics: User Forum
Dec 4, 2009 at 9:30 PM

I have downloaded and installed Terminals v1.8b

I am trying to connect to machines running TightVNC Server, but when I try to connect, I get the following "Sorry, Terminals was unable to connect to the remote machine. Try again, or check the log for more information."

I try again, same error. I click on Tools -> Open Log Folder, yet nothing opens. I can't seem to find the log file.

I'm also trying to connect to a linux server using SSH, but get the same error as described above.

 

Jan 5, 2010 at 4:26 PM

I am having the exact same issue. I found that when installing 1.8b the Terminals.log4net.config file was not created which was the cause of the logs folder and log file to be missing, so I copied the Terminals.log4net.config file from an installation of version 1.7 and now the log folder and log files are being created, however the log only seems to be recording when Terminals starts and stops, so it is not giving me any information that may help explain why VNC and SSH are generating the errors.

 

Thank you in advance for your help

 

Jan 7, 2010 at 5:36 PM

I'm having same issue too - connecting to a server running REAL VNC Enterprise Ed - same log file issue too, however I can connect to a server running Real VNC Standard ed.

Jan 19, 2010 at 10:50 AM

Same issue here with terminals v1.8b.
Cannot connect using SSH, no log file found.
(Telnet runs ok.)

Please help... 

Thank you in advance

Jan 28, 2010 at 1:13 AM

I haven't been using Terminals with VNC connections but will try and look into this soon to fix it....

Feb 8, 2010 at 4:19 PM

GodKratos,

 

Love this app!  Two tings I'd like to mention.

1)  SSH keyboard interactive and password prompt is now working in 1.8c but public key does.

2)  When you close a terminal, it closes two at a time and not just the one you have active.

Thanks for your work.  This app is so close to being "end all"  of connection management.

 

Feb 8, 2010 at 7:21 PM
reddins wrote:

2)  When you close a terminal, it closes two at a time and not just the one you have active.

Never heard of it doing this before.... what method do you use to close a terminal?

Just by clicking the x on the top right or some other way?

Feb 8, 2010 at 7:27 PM

Yes, closing by clicking the x at top right and confirming the close dialog.  Above I meant to say "SSH keyboard interactive and password prompt is not working....."  I get the "Sorry, can't open..." error.  Funny thing though, version 1.7 works for me in password prompt or keyboard interactive.  Something must have been broken in 1.8c

 

Feb 9, 2010 at 2:01 PM

GodKratos,

I copied the Terminals.log4net.config file from a 1.7e install over to the 1.8c folder and I got the log files working to where I could get enough hints on why SSH wasn't working.  SSH is working on the Public Key and Password options but not on Keyboard Interactive.  To make it work on the Password option, the "Save Password" box has to be clicked or use Credential Manager to specify a username/password combination.  If you type the password in and don't choose to save the password, it will not transfer over during Authentication in the routine Routrek.SSHC.SSHConnection.Connect(SSHConnectionParameter param, ISSHConnectionEventReceiver receiver, Socket underlying_socket)

I hope this helps the developers and any other party.

 

Feb 10, 2010 at 12:44 AM

That makes sense.... if you haven't saved the password then how can it use the password to connect?

I guess what is required is to give the user a popup asking for the password if you have chosen not to save it?

Feb 10, 2010 at 2:02 PM

GodKratos,

Well, kind of.  If you didn't type in a password on the connect screen, a popup should definitely come up and ask for it.  I may not have been clear but even if you type in the password on the connect screen, it's not being used during authentication.  Somehow the variable for the password field in the connection screen is not being set when calling the authentication routine.  Hope that makes more sense.

 

Feb 19, 2010 at 1:35 AM
GodKratos wrote:
reddins wrote:

2)  When you close a terminal, it closes two at a time and not just the one you have active.

Never heard of it doing this before.... what method do you use to close a terminal?

Just by clicking the x on the top right or some other way?

Ok, I have found and fixed this issue. The problem only occurs with certain terminal types (Mainly VNC) so does not always happen.

Fixed in changeset 64075

Feb 19, 2010 at 12:31 PM

Many Thanks!  Hey, BTW, how do I compile the changeset.  What compiler do you use or can I run a script in the changeset to compile it?  Thanks again...great app.

Mar 5, 2010 at 7:25 AM
GodKratos wrote:

I haven't been using Terminals with VNC connections but will try and look into this soon to fix it....

Had a chance to look yet? My first use ever of Terminals... VNC and SSH both broken. Not impressed.

 

Mar 5, 2010 at 1:23 PM
jamundso wrote:

Had a chance to look yet? My first use ever of Terminals... VNC and SSH both broken. Not impressed.

As per the review you wrote, use your 'working VNC software' and find some other place to go and be 'not impressed'. Free (as in beer) is what Terminals is and for your first use you write a bad review and then post another negative comment, go and purchase another piece of software or uninstall Terminals and find something that works for you. Constructive criticism is always welcome as are bug reports and posting of possible solutions by looking at the logs of the software and giving the dev's something to work with.

Mar 5, 2010 at 3:19 PM
Edited Mar 5, 2010 at 3:26 PM

Stephen, I agree.  jamundso needs to go somewhere else.  I like everyone's efforts on this software and if one would check the logs like you mentioned, you can get some very good hints on how to get SSH working.  I haven't had any problems with VNC, in fact that worked the first time for me on Windows.  I couldn't get Terminals to connect to a Linux desktop running x11vnc but I'm going to go check the logs and see what I can find.  Probably has something to do with the X11 display.  I'm gonna look in the forum also and post any solutions I find.

 

UPDATE  (For Ubuntu x11vnc server, Terminals 1.9beta): I was testing without a password on the x11vnc server.  If the server uses password authentication, it will work and you have to save the password in the connect screen of terminals.  It also works when connecting to a vnc server without a password but you have to enter a password in the connect screen regardless just to make it work.  The password is ignored by the server in this case.

Mar 5, 2010 at 5:36 PM

If my opinion of Terminals changes, I 'll gladly change my review, or even delete it. For now it stands, especially after installing 1.8c to a second PC with the same exact result : "Sorry, Terminals was unable to connect to the remote machine. Try again, or check the log for more information."

I also should have mentioned that Tools -> Open Log Folder does absolutely nothing, so feel free to let me know where to look for more detailed information about the problem. Maybe the problem with my two computers is the same problem the first four posters in this thread have, or maybe mine is different. In either case, I'm here to research it, and hopefully find a solution. One thing I do know is that there is no network traffic at all from my connection attempts, so maybe it's as simple as I'm a dope and have not setup the location correctly, though it seems easy enough - the VNC server's IP address is in Computer: and the port number is in Port: and I've tried with and without User name:, Password: etc.

I see a lot of potential in Terminals, so I just can't "go somewhere else"... besides, with such an open, honest community why would I want to? :-)

Mar 6, 2010 at 2:14 AM
Edited Mar 6, 2010 at 2:21 AM

I did test this last week using 1.9 beta and did not have any trouble connecting to VNC or SSH connections.

Have you tried the password suggestions above? Make sure you tick the checkbox to save the password or it will not be sent to the connection.

There was an issue with a couple of releases that the terminals.log4net.config file was missing from the releases and was therefore not saving any log information.
If you use the 1.9 beta release that config file exists so the log files should be created correctly.

I have been toying around with using putty as a plugin within Terminals instead of the native terminal emulation we use.
I have got it working ok but there are some problems with being able to resize the putty screen within the terminals window properly and such.
Since putty does not provide any kind of dll or api support it makes it a bit harder to work with.

Mar 6, 2010 at 4:05 AM
GodKratos wrote:

I did test this last week using 1.9 beta and did not have any trouble connecting to VNC or SSH connections.

Have you tried the password suggestions above? Make sure you tick the checkbox to save the password or it will not be sent to the connection.

OK,  I see... so User name, Password, and Save Password are required fields for SSH, VNC, possibly others? Well sure, then it connects now that I know the top-secret combination of settings in the Properties window. I'm sorry, @reddins was right, I really should not have been here in first place. I see now that Terminals is not for me - I'm more comfortable and effective accessing all my systems from a KDE desktop, rather than trying out a Windows program that's not familiar to me. I'll change my rating, as this is partly my fault. So long, and thanks for all the fish.

Mar 10, 2010 at 2:31 AM
Edited Mar 10, 2010 at 2:32 AM

Hi all..

I downloaded the latest version of Terminals today to use for some VNC connections we've got an it draws a black screen and nothing more after connecting to the machine in question.. This same VNC connection works fine with the TightVNC & RealVNC viewers.. Any ideas why this would not work?  I tried RDP to a Microsoft box and it worked fine.. I'm specifying my password in the dialog box and hitting 'save' if that matters.. We are running a rather old version of VNC though -- one of the very early versions -- our executable is dated 1998.. Could that be a problem?

Thanks in advance!

P.S.  I also tried the beta of 1.9 and it gave the same result..

 

Mar 10, 2010 at 8:04 AM
Edited Mar 10, 2010 at 8:29 AM

Hi all !

I have same trouble with version 1.8c and 1.9 beta too: I cannot connect via VNC and SSH. "Sorry, Terminals was unable to connect to the remote machine. Try again, or check the log for more information."

Remote servers - Linux OpenSUSE 11.2, RHEL 4.5. UltraVNC Viewer and Putty are connected with these servers succesfully

PS - I try to connect via SSH to RHEL 4.4 - succes !  Strangely......

Mar 10, 2010 at 10:41 PM

Ok.. My problem is solved.. A few thing I noticed that threw me off a little..

  1. I was trying to connect to an older Solaris 8 box that used a v1 VNC server that used the oldest protocol (3.3?) -- circa 1998? -- this just does not work with any versions of Terminals -- I tried 1.01 (which I do not believe supported VNC at all), 1.6, 1.7e, current 1.8 and the current beta -- you just get a black window and nothing more.  I wonder if it might be good to put a dialog up in such a case and say something like "..l'm sorry but we don't support this old server protocol..." -- once I moved to talking to a Solaris 10 box (running a current VNC server) all was fine!
  2. I wasn't sure what I needed to put into the various fields in the connection dialog for a VNC server -- I initially was putting 5903 for the port and also setting display #3 on the VNC tab which was probably (in hind-sight) trying to connect to port 5906 (adding the two #'s together).  I've now got it using port 5900 and update the VNC display # to 3 (or whatever the display is for that machine)
  3. Is the username/password field applicable for VNC connections?  Not sure.. I put it in but occasionally get prompted for the VNC password after hitting connect....

 

Mar 11, 2010 at 1:22 PM

In regards to item 3 above, the username and password fields do work and if you enter them and then save the password, you can just double-click on the stored connection after that and it will work which begs the advise of setting the master password function for the terminals program when it opens.  Also, the username doesn't matter with the free versions of vnc unless you specifically tell the vnc server to ask for a username.

Mar 11, 2010 at 5:25 PM

Thanks!  That's what I was doing -- no username but did set a password (and no master password).. Seems to work OK.

Mar 24, 2010 at 10:25 PM

I'm currently using 1.8c.  I love having all of my various consoles and terminals in one place.  I have found that in order to get ssh and vnc connections to work, I had to enter the password info in the connection properties and save the password.  I could not get interactive keyboard authentication to work with either ssh or vnc.

There is just 1 main annoyance I have with the ssh connections.  If I have multiple connections open, and I click the tab to return to an open ssh session, it appears as if the ssh session is now in focus, however it will not accept keyboard input. Anything I type goes into the last session I was in before I clicked over to the ssh session.  I actually have to click in the ssh terminal window (after already clicking the tab for the ssh session) before keyboard input is directed to the ssh session.

 

Jan 12, 2011 at 12:07 AM

I've just installed 1.9a and I'm having the same trouble connecting via SSH as described above.

I've tried both creating a username/password via Credential Management as well as opening a new connection and specifying user name, password AND checking the 'save password' box.

Before reinstalling, I did get the message: "Sorry, Terminals was unable to connect to the remote machine. Try again, or check the log for more information." (I must've had a beta version) - now, I see the message "Connecting, please wait..." for a moment, then the tabbed window just closes.

Terminals does an absolutely fantastic job with RDP, I'm hoping you can help me get it to connect to my Linux box (over SSH), too!

Jan 12, 2011 at 2:06 PM

Well hmmm,  it used to work for me as you can see by my response above but I just tried it using 1.9a build 66074 and SSH is not working for me either.  Here's a snippet of the last login attempt I tried.  Hope this helps you "GodKratos".

Connection attempt scenario:
Protocol: SSH (port 22)
Authentication Method: Password  (SSH2)
Username and Password saved (no success in Kbd interactive also)

 

FATAL 2011-01-12 08:58:26,729 402119ms Terminals              Connect            - Connecting to SSH2 Connection
Routrek.SSHC.SSHException: User authentication failed.
   at Routrek.SSHCV2.SSH2Connection.UserAuth() in C:\Temp\terminals\Terminals_1.9-66074\Granados\SSH2Connection.cs:line 152
   at Routrek.SSHCV2.SSH2Connection.Connect(AbstractSocket s) in C:\Temp\terminals\Terminals_1.9-66074\Granados\SSH2Connection.cs:line 70
   at Routrek.SSHC.SSHConnection.ConnectMain(SSHConnectionParameter param, ISSHConnectionEventReceiver receiver, ProtocolNegotiationHandler pnh, AbstractSocket s) in C:\Temp\terminals\Terminals_1.9-66074\Granados\ConnectionRoot.cs:line 236
   at Routrek.SSHC.SSHConnection.Connect(SSHConnectionParameter param, ISSHConnectionEventReceiver receiver, Socket underlying_socket) in C:\Temp\terminals\Terminals_1.9-66074\Granados\ConnectionRoot.cs:line 212
   at SSHClient.Protocol.Connect(Socket s) in C:\Temp\terminals\Terminals_1.9-66074\SSHClient\Protocol.cs:line 170
   at Terminals.Connections.TerminalConnection.Connect() in C:\Temp\terminals\Terminals_1.9-66074\Terminals\Connections\TerminalConnection.cs:line 111

Jan 12, 2011 at 2:18 PM

oops, I see there are many build updates since 66074.  I'll go grab the latest build and try connecting via SSH.

Jan 12, 2011 at 2:51 PM

OK, tried build 81613 with no luck on username/password authentication but public key works which would be expected in this case.  See my log above.  For some reason the UserAuth() function is not lining up with the response from the SSH server.  Godkratos, let me know if you would like more logs or info posted.  Thanks again.