This project has moved. For the latest updates, please go here.
4
Vote

SSH: The negotiation of encryption algorithm is failed

description

I have attempted to setup a simple ssh connection.

I am receiving this error:
The negotiation of encryption algorithm is failed
From the logs:
INFO 2015-03-04 12:54:23,475 264102ms Terminals Connect - Connecting to a SSH Connection
FATAL 2015-03-04 12:54:23,505 264132ms Terminals Connect - Connecting to unknown Connection
Granados.SSHException: The negotiation of encryption algorithm is failed
at Granados.SSH2.KeyExchanger.DecideCipherAlgorithm(String data)
at Granados.SSH2.KeyExchanger.ProcessKEXINIT(DataFragment packet)
at Granados.SSH2.SSH2Connection.Connect()
at Granados.SSHConnection.ConnectMain(SSHConnectionParameter param, ISSHConnectionEventReceiver receiver, VersionExchangeHandler pnh, AbstractGranadosSocket s)
at SSHClient.Protocol.Connect(Socket s)
at Terminals.Connections.TerminalConnection.ConfigureSshConnection(ISecurityOptions security)
at Terminals.Connections.TerminalConnection.Connect()
Here my ssh settings:
Image

Here is my setup for this "favorite":
Image

Here is the error as I see it:
Image

I am able to connect to this host using putty without issue.
I also have ssh installed in my command prompt in windows and am able to connect to this host with that as well.

Can any one point me in the right direction please?

comments

ArmandoT wrote Oct 26, 2015 at 10:41 AM

Same behaviour connecting to Riverbed Steelhead.

wrote Oct 26, 2015 at 10:50 AM

timpouce84 wrote Sep 15, 2016 at 10:31 AM

Hello,

I encounter the same issue.
Please fix that, this is really annoying !

Vamshi0511 wrote Oct 14, 2016 at 10:05 PM

I am also having the same issue, I am able to connect the failed servers with other ssh clients without any issue, only Terminals client is throwing the negotiation error mentioned in the thread. Please let us know the fix , your help is much appreciated

wrote Oct 14, 2016 at 10:06 PM

wrote Mar 13 at 10:01 AM

leSasch wrote Mar 13 at 10:03 AM

Same issue here, any fix-suggestions?