This project has moved. For the latest updates, please go here.

How to disable Terminals News page in v2?

Mar 31, 2011 at 6:54 AM

There was a discussion on how to do this and it worked in the previous version - here. But it doesn't work anymore. Furthermore - the news page that opens up every time I start terminals is out of date - the latest update that it shows is from May 11, 2010.

Mar 31, 2011 at 12:50 PM

Try downloading and building rev #85288.

I had the news problem anoying me as well, pulled source and compiled and doesn't seem to be on that revision of the app.  I deleted the LastUpdateCheck.txt as well just to check.

Apr 12, 2011 at 7:08 AM
Edited Apr 12, 2011 at 7:09 AM

Isn't the rev 85288 the official v2 RC1? It says so on the download page. And I'm using the third build.

Could you post somewhere your compiled build. I don't have the knowledge to compile it myself.

Apr 12, 2011 at 11:44 AM

If you are getting this page disabled every time you start terminals as opposed to once time per day, then I would suspect a permissions issue with the LastUpdateCheck.txt. Can you see what is inside this file?

Terminals is supposed to create/update this file with contains the date and time when this check was performed. If this date is greater than or equal to your system date, it ignores the check. 

Hence setting the contents of this file into the future should always ignore the check.  (I tested this against the third build (21st Feb) and setting the date in the future does work)

For what it is worth, the check is comparing the build date against the rss feed at http://terminals.codeplex.com/project/feeds/rss?ProjectRSSFeed=codeplex%3A%2F%2Frelease%2FTerminals&ProjectName=terminals

I think this feed was updated on the same day as the third build was built (21st Feb 2011) but unfortunately a few minutes later which is why terminals thinks it isn't the latest version.

 

 

 

 

Apr 15, 2011 at 6:41 AM

It seems that changing the date does prevent terminals from doing a version check. I must've done something incorrectly the first time I tried to set the date. My bad.