Alt-Tab using RDP

Topics: User Forum
May 8, 2008 at 1:08 AM
I was wondering if anyone has experienced the inability to Alt-Tab to another app, while in Terminals, when connected with the RDP protocol. If I perform an ALT-Tab, it cycles me to other open apps within my current RDP session. I would like to find a keystroke shortcut to cycle to another open app on my workstation.

This does not happen to me with a VNC session. It works as expected.
Coordinator
May 8, 2008 at 3:02 AM
This is by design of the RDP and most remote desktop protocols (vnc and such). keystrokes are sent to the client window.

just jump out of full screen and give a window context on the local machine.
May 8, 2008 at 1:31 PM

RobChartier wrote:
This is by design of the RDP and most remote desktop protocols (vnc and such). keystrokes are sent to the client window. just jump out of full screen and give a window context on the local machine.


That's the strange thing. I am in a window, not a full screen. And it does not occur when I use VNC. Am I missing something here?

Also, what do you mean by "Give a Window Context"?

Thanks!
May 8, 2008 at 2:28 PM
If that window is focussed then the ALT-TAB is sent to the client session not the local machine. VNC is another protocol. ;)
May 8, 2008 at 3:35 PM

DonGato wrote:
If that window is focussed then the ALT-TAB is sent to the client session not the local machine. VNC is another protocol. ;)


Just curious.. Is there any other keystroke to break you away from the current RDP session?
Nov 30, 2009 at 5:15 PM

If it's a design of RDP why does alt tab work locally on the MS Client(even in full screen)? Unfortunately this is a deal breaker for me :( I was really hoping to use this great client, I just alt+tab way too much.

Dec 1, 2009 at 2:52 AM
NoValidTitle wrote:

If it's a design of RDP why does alt tab work locally on the MS Client(even in full screen)? Unfortunately this is a deal breaker for me :( I was really hoping to use this great client, I just alt+tab way too much.

I agree totally. The MS Client has the Apply Windows key combinations option which lets you specify if they should be directed to the remote machine or your machine.

I thought the Enable Keyboard Accelerator Passthrough option in Terminals might be eqivalent to this. But it doesen't seem to work.

Jan 28, 2010 at 3:11 AM

There is an option on the RDP page for a terminals properties somewhere that can be turned on or off to direct special key strokes to either the client or the host machine.

Jan 28, 2010 at 3:38 AM
GodKratos wrote:

There is an option on the RDP page for a terminals properties somewhere that can be turned on or off to direct special key strokes to either the client or the host machine.

I don't see this option anywhere. Can you clarify where it is?