This project has moved and is read-only. For the latest updates, please go here.

Windows Server 2008 Support

Topics: Developer Forum, User Forum
Aug 5, 2008 at 8:00 AM

first of all, the tool or more striking 'the program' is absolutely great. thanks for sharing with us.

i've read a lot about windows server 2008 support but i still have no clue if there's a workaround or even fix to connect to those hosts. Could someone give me some information?

 - log entry  -
INFO  2008-08-05 08:47:37,742 197390ms Terminals              CheckForTS         - checked to see if is a terminal server. is not a terminal server

thanks a lot


Aug 25, 2008 at 7:14 PM
we fully support w2k8 sku's, tested.
Aug 26, 2008 at 10:00 PM
Hi Rob

first i was glad when i readi this.. but then i tested on both vista and wxp to connect to a WS08 .. to my disappoinment it does not work..

INFO  2008-08-26 18:10:17,417 50370ms Terminals              CheckForTS         - checked to see if <someserver> is a terminal server.  vmdsrv002 is not a terminal server

but workstations are non-domain member - maybe that's an issue?

Aug 26, 2008 at 10:39 PM

Sounds like something unlreated to Terminals to me.

give this a try:

start, run
mstsc /v:[HOST]

where [HOST] is the machine your trying to connect to

see if that can connect.

Aug 27, 2008 at 7:34 PM
Edited Aug 27, 2008 at 7:36 PM
well, that works of course.

btw, the whole thing works pretty well on windows 2003 servers .. only WS08 are affected..
Sep 2, 2008 at 5:05 PM
Ive been running this tool on 2003 and 2008 box's connecting both OS's with no issues at all.

Would you be able to clean your /log folder (delete *.*) and then start the app, try to establish your connection, and then exit and post up the resulting log file?


Sep 8, 2008 at 3:34 PM
can i change the verbose level somewhere? because i don't get an entry in the logfile ...


Sep 8, 2008 at 11:19 PM


    <level value="ALL" />
    <appender-ref ref="RollingLogFileAppender" />

All is everything, which is the default.
Sep 23, 2008 at 12:48 PM
Still the same issue over here .. could it be, that the check for CheckForTS has a bug?

INFO  2008-09-23 13:39:56,233   357ms Terminals              Main               - Terminals 1.7b started
INFO  2008-09-23 13:42:14,506 138630ms Terminals              Connect            - Connection Failure.
System.NullReferenceException: Object reference not set to an instance of an object.
   at Terminals.TerminalServices.TerminalServicesAPI.GetSessions(String ServerName) in C:\Source\Terminals\Terminals\TerminalServices\TerminalServicesAPI.cs:line 193
   at Terminals.TerminalServices.TerminalServer.LoadServer(String ServerName) in C:\Source\Terminals\Terminals\TerminalServices\TerminalServer.cs:line 12
   at Terminals.Network.Servers.TerminalServerManager.button1_Click(Object sender, EventArgs e) in C:\Source\Terminals\Terminals\Network\Servers\TerminalServerManager.cs:line 33
   at Terminals.Network.Servers.TerminalServerManager.Connect(String server, Boolean headless) in C:\Source\Terminals\Terminals\Network\Servers\TerminalServerManager.cs:line 68
INFO  2008-09-23 13:43:13,151 197275ms Terminals              CheckForTS         - checked to see if vmdsrv001.vmd.local is a terminal server.  vmdsrv001.vmd.local is not a terminal server
INFO  2008-09-23 13:43:40,121 224245ms Terminals              CheckForTS         - checked to see if vmdsrv001.vmd.local is a terminal server.  vmdsrv001.vmd.local is not a terminal server
INFO  2008-09-23 13:43:49,281 233405ms Terminals              Main               - Terminals 1.7b stopped

kind regards,

Sep 23, 2008 at 3:29 PM

The logic around "Check for Terminal Server" is this:

Once I connect to a machine that supports the RDP Protocol I spawn a thread to examine that server to see if I can also connect to the features exposed via tsadmin.exe.  (for example listing sessions, logging off sessions, killing sessions, etc..).  There is no real easy way of doing this other than attemping the connection and waiting for the failure to take place. 

There are a few places where, if that does fail, i capture and log it, which is what we are seeing above.  Given that I essentially black-hole the exception and it is off on a seperate thread it should not interfere with the main RDP session which was just opened.  So your connection should be established correctly.

With that said, I did add a bit more logic around line 193 to check for a null object (if it cant retreive the session info).  I doubt it, but lets see if that will solve the issue.

Check for it in the next release.

Dec 12, 2008 at 1:06 PM

just tried it again, still no luck.

My Host / OS: Vista with UAC enabled, starting/running Terminals as Administrator, Logged on as Domain Admin, logically i'm in the same Domain as the Remote Hosts
Remote Host: Windows Server 2008 Enterprise (multiple, all Domain Members)

Connections to Windows 2003 Server can be established.

mstsc /v:<remoteHostAddr> works perfectly

Version: 1.7c (binary:, copyright 2006;))


<?xml version="1.0" encoding="utf-8" ?>
  <appender name="RollingLogFileAppender" type="log4net.Appender.RollingFileAppender">
    <file value="logs\\CurrentLog.txt" />
    <appendToFile value="true" />
    <datePattern value="yyyyMMdd" />
    <rollingStyle value="Date" />
    <filter type="log4net.Filter.LevelRangeFilter">
      <acceptOnMatch value="true" />
      <levelMin value="INFO" />
      <levelMax value="FATAL" />
    <layout type="log4net.Layout.PatternLayout">
      <conversionPattern value="%-5p %d %5rms %-22.22c{1} %-18.18M - %m%n" />

    <level value="ALL" />
    <appender-ref ref="RollingLogFileAppender" />


INFO  2008-12-12 13:52:02,891    93ms Terminals              Main               - Terminals 1.7c started

no more entries in the log...i don't know what to do .. any hints?


Jan 8, 2009 at 12:52 AM
To be clear, are you trying to simply RDP (Terminal Service) into a Windows Server 2008 machine?  Or are you trying to use the more advanced Terminal Services tools like the "TS Admin" Tab in the Networking Tools window?

I have tested both with Server 2008 with no issues at all.

Feb 4, 2009 at 7:39 PM
It also appears that smartcard redirect does not work on Windows Server 2008 clients :(  I have confirmed that it works as it should on my server 2003 connections however this is not the same for the 2008 clients.

I'm on Windows 7 build 7023
Feb 15, 2009 at 8:59 AM
Rob, which setting did you choose when configuring WS08 RDP? using 'Remote Desktop with Network Level Authentication (more secure)' or 'running any version of Remote Desktop (less secure)'?