This project has moved and is read-only. For the latest updates, please go here.

Trying to run it under linux.

Topics: Developer Forum
Sep 8, 2008 at 1:01 PM
I just wanted to report that I tried to run terminals under wine in windows (with .net 2.0). The application launches but hangs up immediately afterwards. Seems stuck there for a while and then dies.

Haven't tried it under mono.

Sep 8, 2008 at 11:20 PM
Does a "logs" folder get created?  Could you post "CurrentLog.txt"...

Sep 8, 2008 at 11:34 PM
Here it is.

INFO  2008-09-09 10:28:20,966  1261ms Terminals              Main               - Terminals 1.7a started
INFO  2008-09-09 10:29:31,320   623ms Terminals              Main               - Terminals 1.7a started

As you can see not much there. Is there a debug flag or something?

This is from an earlier log.

INFO  2008-09-08 23:38:34,191   648ms Terminals              Main               - Terminals 1.7a started
ERROR 2008-09-08 23:39:24,253 50710ms Terminals              nextButton_Click   - Loading default shortcuts in the wizard.
System.OverflowException: Arithmetic operation resulted in an overflow.
   at IconHandler.IconHandler.IconsFromFile(String Filename, IconSize Size) in C:\Source\Terminals\Terminals\IconHandler.cs:line 86
   at Terminals.FirstRunWizard.nextButton_Click(Object sender, EventArgs e) in C:\Source\Terminals\Terminals\Wizard\FirstRunWizard.cs:line 97
INFO  2008-09-08 23:40:13,592   935ms Terminals              Main               - Terminals 1.7a started

I am reluctant to try mono yet. On ubuntu mono conflicts with the .NET 2.0 installed under wine.

Unfortunately you have choose either one or the other.

I can install mono for windows under wine I suppose.
Sep 8, 2008 at 11:41 PM
To tell you the truth, given that this sucker has so much embedded reliance on the Windows platform the best I could do is black hole/log exceptions and see how far you will be able to get with getting it running.

It relies heavily on ActiveX and I just dont see it happening...

Thanks for trying it out though.
Sep 9, 2008 at 12:37 AM
ActiveX is supposed to work under wine (by and large).

The problem might be the RDP components. Obviously wine does not come with the RDP client.

Do you know which DLLs (or assemblies) your program needs and if I can download them from someplace?

Microsoft won't let me download the RDP client for windows because I am not running windows (not genuine!!!).

Sep 9, 2008 at 12:47 AM
Check here:

Download that changeset, which does include the DLL's you should need.