This project has moved and is read-only. For the latest updates, please go here.

Cannot SSH to AIX

Topics: Developer Forum, User Forum
Aug 7, 2014 at 8:59 AM

I have many AIX 6 systems to administer and tried to use terminals in order to manage my connections.

All my Linux and RDP connections are working and it's fine to use.

But all my AIX 6 in SSH connections are ending with this error :

"Sorry, Terminals was unable to connect to the remote machine. Try again, or check the log for more information.

The negotiation of encryption algorithm is failed"

Here are my logs :

INFO 2014-08-07 09:54:46,705 237679413ms Terminals SaveHistory - History saved. Duration:188 ms
INFO 2014-08-07 09:54:46,713 237679421ms Terminals Connect - Connecting to a SSH Connection
FATAL 2014-08-07 09:54:46,763 237679470ms Terminals Connect - Connecting to unknown Connection
Granados.SSHException: The negotiation of encryption algorithm is failed
à Granados.SSH2.KeyExchanger.DecideCipherAlgorithm(String data)
à Granados.SSH2.KeyExchanger.ProcessKEXINIT(DataFragment packet)
à Granados.SSH2.KeyExchanger.SynchronizedKexExchange()
à Granados.SSH2.SSH2Connection.Connect()
à Granados.SSHConnection.ConnectMain(SSHConnectionParameter param, ISSHConnectionEventReceiver receiver, VersionExchangeHandler pnh, AbstractGranadosSocket s)
à Granados.SSHConnection.Connect(SSHConnectionParameter param, ISSHConnectionEventReceiver receiver, Socket underlying_socket)
à SSHClient.Protocol.Connect(Socket s)
à Terminals.Connections.TerminalConnection.ConfigureSshConnection(ISecurityOptions security)
à Terminals.Connections.TerminalConnection.Connect()

I have truly no idea why it's not working, everything is just fine with other clients and it's no more than SSH connections to AIX servers. Has AIX 6 any protection against connections with Terminals or have I missing something in the options of Terminals ?

Thanks for your responses.
Jan 20, 2017 at 10:45 AM
Anyone have a fix for this?

It very annoying not having a single place to access all windows and ssh servers.

Is there a new version of the granados.dll that we can use or something?
Jan 21, 2017 at 8:30 PM
We are working at new SSH implementation. This new version does not depend on granados.dll.
Feb 12, 2017 at 11:47 AM
Any idea when it will be available?

Is there something I can help do? Haven't programmed in c++ in ages though.
Feb 14, 2017 at 12:17 AM
Sure, if you are familiar with C#, create patch file for any fix you are able to provide and we will apply it.
Feb 17, 2017 at 9:59 AM
Awesome, i used the Granados.dll from Poderosa.

Then changed the connections SSH options to password and it actually worked!!!

KarlosChuar, can you confirm this is fine?

Using Terminals 3.6.1

Now I can do both RDP and SSH :)
Feb 17, 2017 at 8:06 PM
Not sure what do you mean. Do i undestand your steps as follows:
1). download granados.dll from Poderosa project and replace our dll
2). restart the app and ssh starts working?
Feb 18, 2017 at 5:34 AM
Yes but you also need to pick the password option for the connection.

The keyboard and private key approach still doesn't work.
Feb 21, 2017 at 12:36 AM
Hi KarlosChuar,

Any idea when the new SSH integration will be out?

Now that SSH is working I have seem terminals crash many times when selecting text from the SSH console.

Anyway ideas to get around this?
Feb 22, 2017 at 12:21 PM
No workaround is available.
For the roadmap see