This project has moved and is read-only. For the latest updates, please go here.

Version 1.8a crashes at startup on Win7

Topics: Developer Forum, User Forum
Oct 20, 2009 at 10:35 AM
Edited Oct 20, 2009 at 10:35 AM

I tried version 1.8a, but it crashes on startup. I can't find the error in Event log. Is there a log file to see what's happened?

I have Win 7 RTM 64bit, IE8.

I'm glad that you are working on Terminals and this is not a dead project. The software helps me a lot.

Thanks for help

Oct 22, 2009 at 7:41 AM

I have the same problem. It does not work with Windows 7 - 64 bit.

Oct 22, 2009 at 5:22 PM

Open the path where the application was installed, there should be a logs folder.

CurrentLog.txt should be what your looking for.

Please post anything relevant.



Oct 22, 2009 at 6:47 PM

I can't find the file anywhere on the drive. I neither can't in version 1.7a's folder.

I tried to change Win7 Compatibility mode for the terminals.exe, but didn't help.

Oct 22, 2009 at 6:58 PM

I have personally ran the app on x64, just not Win7 x64 with no issues.

Is the crash quite generic?  Does it give any details at all?  I dont have access to a Win7x64 build right now to test it out...


Oct 22, 2009 at 7:57 PM

Here are two the solutions:

1. Always run Terminals.exe as administrator (Is there a way to avoid this?)
2. Download the Binaries (not the Installer) to a location other than Program Files and run as normal user

I think the problem is that the program tries to create files to it's directory (in Program Files (x86)), and there file modifycations are allowed only for administrator. The authors may consider placing the config and other files to user's setting directory (in  c:\Users\... or c:\Documents and Settings\...), or handle the problem in an another way.

A big problem:
When I use Step 1 (from Program Files, see above), there is something wrong with window handling, so I can't open any new windows, I can't connect to a machine with RDP. When I use Step 2 (for example in d:\Terminals, see above), it works.

Some small bugs:
1. after install, toolbars are locked but I still can move them. After Unlock + Lock, they are really locked.
2. Tools / Networking tools doesn't do anything
3. In Favorites on the left, after right-click, I can't use Ping, Tracert, etc. Maybe it's connected with bug Nr. 2 above.
4. Favorites toolbar is empty for me, but I have some Favorites
5. When I click Full Screen, it changes, but an another window comes to the top (for example my opened IE)

Some functions tha I miss:
1. A way to send Ctrl+Alt+Del to the machine I'm in with RDP
2. A way in Terminals to Log Off from DRP (not disconnect)
3. An easier way to manage Tags, for example Favorites / right-click / Tags / and click

To the authors: I like your software really much, it helps me and my colleagues a lot. You are making a good job.

Ps.: What is the correct way to report these kind of bugs, wishes, problems: "Discussions" or "Issue tracker"? I'm new on CodePlex.