This project has moved. For the latest updates, please go here.

Version 1.8a ssh goes full screen

Topics: Developer Forum, User Forum
Oct 22, 2009 at 9:38 PM
Edited Oct 22, 2009 at 9:39 PM

It seems that when I open an ssh session, Terminals goes full screen automatically, even if I configure the connection open in a seperate window.  Also, my menu bars all disappear after I go back to regular view, even if the menus were locked.  In RDP, I can tell Terminals to "fit in window", but SSH does not have this option.  Any ideas on a solution would be great, as I am hoping to dump putty and move completely to terminals.

Coordinator
Oct 22, 2009 at 9:44 PM
Which build?



On Thu, Oct 22, 2009 at 2:38 PM, [email removed] wrote:
> From: jnegro1176
>
> It seems that when I open an ssh session, Terminals goes full screen
> automatically, even if I configure the connection open in a seperate
> window.  Also, my menu bars all disappear after I go back to regular view,
> even if the menus were locked.  In RDP, I can tell Terminals to "fit in
> window", but RDP does not have this option.  Any ideas on a solution would
> be great, as I am hoping to dump putty and move completely to terminals.
>
> Read the full discussion online.
>
> To add a post to this discussion, reply to this email
> ([email removed])
>
> To start a new discussion for this project, email
> [email removed]
>
> You are receiving this email because you subscribed to this discussion on
> CodePlex. You can unsubscribe or change your settings on codePlex.com.
>
> Please note: Images and attachments will be removed from emails. Any posts
> to this discussion will also be available online at codeplex.com



--
Rob Chartier
Microsoft MVP ASP.NET, ASPInsider
http://weblogs.asp.net/rchartier
http://twitter.com/robchartier
604-338-2512
Oct 23, 2009 at 1:18 AM

I'm not seeing a build anywhere, but it's version 1.8a.  I just downloaded the stable version off of the website today and installed it for the first time.

 

Oct 23, 2009 at 9:13 AM
Edited Oct 23, 2009 at 9:15 AM
jnegro1176 wrote:

It seems that when I open an ssh session, Terminals goes full screen automatically, even if I configure the connection open in a seperate window.  Also, my menu bars all disappear after I go back to regular view, even if the menus were locked.  In RDP, I can tell Terminals to "fit in window", but SSH does not have this option.  Any ideas on a solution would be great, as I am hoping to dump putty and move completely to terminals.

 Just sorted out similiar problem - I've recently created a http link and it always was opened in Fullscreen. Resolution "quick and dirty" - close Terminals, backup config file, open the original config, find section related to your connection, find parameter desktopSize equals to "FullScreen" and replace with "FitToWindow", save config and enjoy Terminals.

Oct 23, 2009 at 1:18 PM

I confirmed this works for ssh.  I would suggest to development that there be a global option to set a default for screen size.  I honestly never use full screen, as I prefer the tabbed windows.  At the very minimum, all connection types should have a screen size option so that editing the config file is not necessary.

Oct 29, 2009 at 10:52 AM

I'm glad there's a workaround for this - I won't speak for others, but this bug made version 1.8a nearly useless to me.

Does this mean that the "FullScreen/FitToWindow" behaviour for SSH was somehow changed since 1.7? What really disturbs me is the fact that this bug is so easy to reproduce. Not a single developer tried connecting to SSH, or what?

RobChartier, you mention a build number. Should it begin with the digit 2 for 1.8a? If that's the case, the number is not displayed completely as it falls outside of the About Box window bound (using XP Classic theme, 96dpi)

Oct 30, 2009 at 1:24 AM
Edited Oct 30, 2009 at 1:40 AM

Fixed in Change 60693.

A new resolution was added in 59912 which altered the default behaviour.

Oct 30, 2009 at 8:26 AM

Maybe it doesn't do that after upgrading the config file? I didn't upgrade, new install.

Nov 1, 2009 at 7:23 PM

The problem was only for the default connection behaviour for new favourites.

If you have configured your connections for Auto Scale already then there will not be a problem.

Nov 2, 2009 at 4:21 PM

Also on a related note, for some reason all my menus have now disappeared, and I have no where to right click to put them back.  I just have the list of Favorites and History, and a terminal window.  Can't add new clients etc...  any way to get them back?

Nov 3, 2009 at 1:42 PM
Edited Nov 3, 2009 at 1:43 PM

This has been haunting me for a while too.  To get the default Menu and toolbar back...

  • First, close Terminals.
  • Open the folder where you have Terminals installed and look for a file called "Toolstrip.settings". 
  • Delete the file.
  • Terminals will recreate it using defaults when you run the program.
  • After adjusting your toolbar and menu settings and getting them the way you want exit the program and make a copy of "Toolstrip.settings".
  • For some reason the program seems to "loose" the settings periodically.  When this happens you can just make a copy of your backup file and rename it "Toolstrip.settings" and you will be back in business.

I hope this helps

Chuck

Nov 3, 2009 at 10:38 PM

Have a go using 1.8b

I think all the issues with menus & tabs disappearing should be gone now.

Nov 4, 2009 at 7:48 AM

Thanks for the update, will try.

Nov 4, 2009 at 1:32 PM

I just upgraded and confirmed that all the issues I was experiencing have been resolved by 1.8b.  Thanks to the dev team!

One word of advice to reiterate that was mentioned above - when you install 1.8b, delete the toolstrip.settings file so that you can start with defaults on the menus.