This project has moved. For the latest updates, please go here.

No automatic login to Windows 2000 TS

Topics: User Forum
Feb 17, 2007 at 9:24 AM
Is that a known protocol limitation or something else?
Coordinator
Feb 22, 2007 at 4:48 PM
Try to updgrade to RDP 6.0.
Feb 22, 2007 at 6:25 PM
You mean at the client?
Mar 10, 2007 at 4:22 PM
There's a setting on the Terminal server that enables\disables automatic login. It might be disabled:
1. Start->Run->tscc.msc
2. under connections, right click RDP-TCP and click properties.
3. Under "logon settings" make sure "Always prompt for password" is not checked.
Mar 26, 2007 at 7:40 PM
Thanks, that did it. :)
Sep 15, 2010 at 9:45 PM

I just recently ran into this problem on several old Windows 2000 boxes.  Sometimes the setting above isn't enough, you also have to disable the "DontDisplayLastUserName" registry setting.  See this article: http://support.microsoft.com/kb/260711